Onewheel not charging - blinking red



  • Need some help decoding this. I recently took my onewheel on the beach and it rode fine. Died in the middle of the ride so I brought it home and put it on the charger. The onewheel doesn't charge, the charger block blinks red and makes a tick sound with every blink, and the led ring on the power button blinks as well. Any help?



  • Same thing happened to me after a beach ride. Contact OW you will have to mail it back to them for fixing.



  • @MichaelW dang. How long did it take for them to fix it and get it back to you?



  • Any charges or anything?



  • @uncbeast5 said:

    Any charges or anything?

    If it's under a year, everything will be free. I mailed mine (different problems) from Alabama, and I got it back in 12 days (counting shipping to and from).



  • Hello, same thing happen to me today. I didnt use my board during one month. I decided to charge it fully. After few minutes, the charger started to blink red with à little noise tic tic tic. Could you guys tell me if i Can fix it by myself ?



  • @djmars said in Onewheel not charging - blinking red:

    Hello, same thing happen to me today. I didnt use my board during one month. I decided to charge it fully. After few minutes, the charger started to blink red with à little noise tic tic tic. Could you guys tell me if i Can fix it by myself ?

    Email support and go ahead and get the ball rolling on it. If it won't turn on and run, then it's probably going to have to be sent off... I know that's painful, but their turnaround has gotten better.


Log in to reply
 

Looks like your connection to Onewheel Forum was lost, please wait while we try to reconnect.