Issues using v2 iOS app on v1 Onewheel.



  • Heads up, there's a lot of discussion on Facebook group about poor performance in extreme mode when set through the new app on iOS, while the old Android app does it right. There might be a bug in the new app - maybe FM can ask the app developer(s) to investigate?



  • @snwbrdwndsrf I haven't had any issues. I can't imagine the app on your phone making any difference with the firmware on the board.



  • @J-Glide said in Issues using v2 iOS app on v1 Onewheel.:

    @snwbrdwndsrf I haven't had any issues. I can't imagine the app on your phone making any difference with the firmware on the board.

    I would agree. The ride modes are defined in the firmware of the controller on the board. The app just says "use this on now". I have been using it with v1 OW's with no issues and have been up to 25mph with the new app connected. Not noticing and performance issues.

    Was anyone more specific about performance issues?



  • You're probably right in general, although it sounds as if the ride modes are essentially enumerated. I seem to recall early reports that the OW+ used different mode enumerations than V1 - so it is conceivable that the new apps are pushing different mode numbers and could thus cause the board to behave differently.



  • @J-Glide that's literally how digital shaping works.



  • @darthj0n What are you referring too?



  • @iiikz that's what I was thinking, but also thought I'd leave the specifics to the developers. I know there are at least two (possibly three) different hardware configurations for the v1 that require different firmware versions, so it could be that only a specific firmware version is affected.



  • Here is a copy of the FB post, though this has come up a few times in other post discussions.

    @redacted / FB said:

    Spoiler Alert: Warm water discovery here,
    So for 2 weeks I have been testing changing modes, New App iOS vs Old App Android, Firmware 3056, when switching the modes in Crapdroid(Old App) Extreme mode is awesome, Elevated is strong and fast, With the new App Extreme is slow and Elevated has a tremendous pushback elevating the nose and killing my knee, can anyone confirm?



  • @snwbrdwndsrf But elevated mode is SUPPOSED to ride nose up. Not sure why he's saying there's something wrong there.



  • @snwbrdwndsrf said in Issues using v2 iOS app on v1 Onewheel.:

    Here is a copy of the FB post, though this has come up a few times in other post discussions.

    @redacted / FB said:

    Spoiler Alert: Warm water discovery here,
    So for 2 weeks I have been testing changing modes, New App iOS vs Old App Android, Firmware 3056, when switching the modes in Crapdroid(Old App) Extreme mode is awesome, Elevated is strong and fast, With the new App Extreme is slow and Elevated has a tremendous pushback elevating the nose and killing my knee, can anyone confirm?

    elevated...nose elevated!?wtf....hmmmm, strange....I bet you was goin 30mph also??



  • @thegreck I think the point is that they are reporting that the board ride is different when commanded from different apps.

    Regardless of which is "better" or "right" - the expectation is that they should be the same whether selected through Android app, iOS app, or manual mode selection process.



  • @timvdp said in Issues using v2 iOS app on v1 Onewheel.:

    elevated...nose elevated!?wtf....hmmmm, strange....I bet you was goin 30mph also??

    Is that you John Wayne? Is this me?



  • @J-Glide said in Issues using v2 iOS app on v1 Onewheel.:

    @snwbrdwndsrf I haven't had any issues. I can't imagine the app on your phone making any difference with the firmware on the board.

    I would have thought so too, but now I'm not 100% sure on that. I've noticed that my board is different after the new app and I've started hitting pushback a little sooner in Extreme (at around 13.3MPH instead of ~14). And I'm starting to wonder if there are individual settings for things like pushback, elevation, etc. that just get sent to the board from the app. It might just have an API to leave them open to personal riding modes, etc. later on...



  • @mekon LOL



  • I just heard that the iOS app was updated today, and it has fixed digital shaping issues for some when used with a v1 Onewheel. I don't own an iOS device - has anyone else seen a similar improvement with today's app update?


Log in to reply
 

Looks like your connection to Onewheel Forum was lost, please wait while we try to reconnect.