Over regeneration error - battery still at 100% after 11% usage



  • @skyman88 said in Over regeneration error - battery still at 100% after 11% usage:

    So I've just accepted it.

    That's it ! But I hope we get some words about it from FM...one day....
    @hafeedgood your english spoken is so dope bro ! 😂😂😂



  • this is a pretty straightforward software bug, given the symptoms. I believe it is literally some mundane math error, since I can use 100 - (% used - % regen) as a perfectly accurate gauge of remaining battery while the app continues to show 100% for miles. The app (or the board) could do that same math, and often does so correctly I presume, but somewhere a bug is breaking it for many of us. The good news is that means it will IMO be fixed with firmware at some point, even if FM never actually acknowledges the obvious bug here.



  • @readysetawesome That would be nice. I haven't contacted FM about this issue. Perhaps it will be escalated if we all reported this problem to them?



  • I have also run into this problem and FM wants me to send the board back. I've run it down to dead and then charged overnight, no luck. I was thinking of charging to 100% then disconnecting the wires from the control module where the BMS is, maybe it will re calibrate. Has anyone tried anything that works? This is super frustrating because I know it's a software problem and could easily be remedied.



  • Problem solved

    problem solved!



  • @vspot415 I tried disconnecting all the wires for a couple minutes, no luck.



  • Note that powering down the board resets the “usage” measurement so it won’t be accurate again until you charge all the way to green light.



  • The only way is to go off cell voltage, I know I'm dead at around 2.8v per cell



  • @readysetawesome really !? Thanks for the tip! I will try!



  • Bros for us slower learners here, what is it we learned? I'm not clear :) PS what is 'usage' showing?



  • @groovyruvy said in Over regeneration error - battery still at 100% after 11% usage:

    Bros for us slower learners here, what is it we learned? I'm not clear :) PS what is 'usage' showing?

    Learned to use cell voltage as "the truth" for remaining battery.

    I haven't seen what my usage bar looks like after riding but I need to start paying attention. Doesn't show up on the Apple Watch.... bummer.



  • @groovyruvy usage tells you how many % of your battery’s full charge have been consumed on this trip (since the board was switched on). Knowing this you can start with a fully charged board (ignore the app, wait for green light on on the charger), and as long as you don’t power off the board you know the battery will empty when usage reaches about 100%.

    I believe usage is a reflection of amp-hours flowing out of the battery, which the app is counting accurately (can be seen in the settings screen) but for some reason it isn’t applied to the battery gauge in the same way as the usage bar.

    (There may be a slight bonus from regeneration which you can also read in the app but that’s usually only 10% or less for me.)



  • There is no question that battery life expressed as a percentage is not functioning as a reasonable person might expect and cannot be trusted at all as a result of this. It seems to report the battery is more charged than it is possible for it to, in fact, be.

    If you charge to 100% and ride the ONEWHEEL on flat ground for a mile, there is no reasonable way for the battery to remain at 100%. It does this.

    I think this may be considered a feature by the developers or parties who would be held liable in the event of an overcharging-related lawsuit.

    Perhaps they already have a lawsuit in the making and just backed off the software really quick to avoid a class-action.

    Perhaps the company should admit what they have done. Perhaps admitting what they have done may be presented by a plaintiff as evidence of previous wrongdoing.

    In any case, I expect there will be no answer from the company as they have had plenty of time to answer already.

    It appears the "bug" is the company "erring on the side of caution." Just my guess.



  • @rk_d I doubt these issues are actively malicious. Chances are, there are bugs in the software, firmware, or hardware that they don't know how to track down and/or don't have a solution for. They are probably dragging their feet because they don't have a way to fix our boards, and the cost of completely replacing them is too high.



  • @rk_d above I suggested a good workaround using “usage” bar in the app. I suggest you try it, it’s a lot less effort than trying to get through to FM. Most software bugs, which this clearly is, are honest mistakes and often the delay in having them addressed is a dysfunction of the company support apparatus, not engineers. This will be fixed with a firmware update, just a matter of time.



  • @readysetawesome @fabuz @SeattleCommuter

    I can confirm the Usage % is pretty spot on from a full charge. I used to get 6 miles per charge and tonight at the 3 mile marker I had used 51% battery. So those line just about perfect.

    Today I also ignored the barrage of notifications about over regen after I had used about 10% of the battery. The board Never shut off braking or going down hill. So the warnings are false.



  • @skyman88 exactly, all the app notifications should be ignored since they’re based on the broken gauge.



  • @readysetawesome said in Over regeneration error - battery still at 100% after 11% usage:

    @skyman88 exactly, all the app notifications should be ignored since they’re based on the broken gauge.

    It's possible that the broken gauge could just be a small portion of users and that the software developers have absolutely no idea what we are talking about because most people don't have a problem.

    All I know is that I don't trust it because it's clearly not telling the truth.



  • I just wanted to get some feedback if any of you were using portable chargers when this started happening. I noticed issues after charging from my solar charger.



  • @vspot415 said in Over regeneration error - battery still at 100% after 11% usage:

    I just wanted to get some feedback if any of you were using portable chargers when this started happening. I noticed issues after charging from my solar charger.

    Nope, don't own one. And this had started for me before the firmware upgrade.


Log in to reply
 

Looks like your connection to Onewheel Forum was lost, please wait while we try to reconnect.