Android 4.4 Kitkat not supported? Seriously?