App crashes when board disconects

  • Not sure how common this is but:
    Say I have the app running in the background when the phone (Samsung Galaxy Note 4) is locked, if I turn off the board the phone will lock up and not allow me to unlock it.
    Its as if the app takes all of the processing power of the phone and will not allow even the operating system to run.
    The same thing happens when I try to record a ride, i haven't given it too many goes, but it doesn't even last a minute in that mode.
    Just wondering if this is happening to anyone else

  • Many of us are not experiencing that issue. I have a Nexus 5x.

    I suggest, uninstalling the app, reboot the phone and reinstall the app.

    Let us know if that fixed it.

  • @Holsty
    I have the same problem on a Samsung S5, another rider complained of the same problem on his Samsung.

  • Have you done what @SkyPilot recommended and uninstalled and then reinstall the app? Those that have done this have usually reported it resolved any issues.

  • I haven't had this happen either- Samsung Galaxy S7. Have you tried closing all other running apps before starting the Onewheel app?

    Have you tried using a different unlock mechanism? For example, changing it to PIN or Pattern. You can also try enabling the smart lock feature in Android if your version has it. This makes it trust specific Bluetooth devices so you could set it to never lock the phone when you're connected to the Onewheel.

    Another thing you might try is to configure Android to limit the number of running processes, but this requires enabling Developer Options (Settings->About Device->Software infromation->Tap build number 7 times). Then, Settings->Developer Options->Limit background processes->At most, 4 processes. If it doesn't help, you can always switch it back to the Standard Limit.

  • I have this same issue. I have uninstalled/reinstalled many times, after reading this I uninstalled, rebooted, installed and still have same issue.
    When you try to wake the phone from screen lock it says at top connecting onewheel...
    and you can not wake it as it is to busy, phone gets hot and battery gets emptied. have to hold power button and quickly it restart, even that is a little difficult, especially while riding. After the restart app works great until the combination of disconnect and screen lock.
    I have even seen it while the screen stays on. All of a sudden screen goes black and you can not wake it.

    Have no issues otherwise but this makes the app useless...

    Galaxy Note 4 Android 6.0.1 Rock Solid unless using this app...

  • @ericn I think there is a setting in the app where you can switch off auto-connect.
    This might solve the problem.

  • @ericn I had similar issues. Finally gave up and installed the 3rd party POWheel app for Android, and while it wasn't perfect I had an easier time connecting.

  • @ericn, Those are the exact same issues i have (same phone and android version as well), you just worded it better...
    I have tried uninstalling, rebooting and reinstalling and still have the same problem.
    I also have tried closing all other open apps, and still have the same issue. I am still yet to try @joseph's debugging tool method to see if that will change anything.

    Just seems like old Samsungs don't like this app...

  • @Holsty So went on 12 mi trail ride!, powheel worked great but in the interest of diagnosing, I went back to onewheel app. tried turning off my watch (pebble) bluetooth.
    This makes the phone crashes way less often. It still crashed but only one two times. To be clear with my watch in airplane mode, I have no other bluetooth devices with me, just phone and ow. I have not tried turning off autoconnect thanks for tip I will try that today, just saw the note sorry.

Log in to reply