Over regeneration error - battery still at 100% after 11% usage

  • Nope I spoke too soon.. reaching 0% had no affect on being stuck at 100% after the next recharge

  • I've improve my battery accuracy doin' that:
    Charge the board with the cell phone app on .
    Wait for the let's ride notification (don't wait for the green button on the charger).
    Go for a big ride till the board need juice....charge till the app say let's ride...
    That's how I do for the moment...
    I'll see later for a complete charge to balance the cells ....

  • Yep, same here. Just listened to the regen warning go off for the first 15 mins of my commute. Do we think this is an app issue or a battery problem? My cells never all balance (~3.58 - 3.62v) even after 48hrs on the charger following a full drain.

  • Keep on this issue guys. My OW+ has the same problem. I go for a good 3 - 4 km's and the app still says the battery level is 100%. The level indicator does move down eventually but once it drops, it drops quickly making it as a power gauge pretty much useless. I have to monitor the distance traveled as a better indicator. I try to make sure I am back in the car or home by the time I hit the 10 km mark.

    In the diagnostics section, the cell voltages are all declining properly. In fact when I go on a tandem ride, the newer OW+ (which has a linear battery gauge) voltage indicator drops down at about the same rate as the older OW+ that has the out-of-calibrated battery gauge.

    I did a complete app delete and re-install where I had to reconnect my OW's. The battery gauge behaviour remained out of skew so my impression is that the mapping of cell voltages to a % remaining is done on the OW rather than the app. I can also confirm this notion by checking the battery indicator on my son's OW app. I suspect it will be the same.

    I don't want to initiate a firmware board reset unless FM tell me to as my lifetime odometer may be cleared.

    What should we do now? Sending my board back to FM is not my preferred option.

  • Hello@gadgetrider, lot of french rider had the same problem batterie gauge...
    I stop charging my+ when '' let' s ride '' signal appears even if it's red !
    Then the first km will be normal and at the end of the ride gauge seems normal... No 'need some juice' at 10/20or others incohérent %.

  • @hafeedgood @Gadgetrider @frosty @fabuz

    We are all in the same boat. I've had this issue for 3 months and the battery capacity has not been effected. I tried doing what @fabuz recommended above for a while but it also meant you had less than 100% range when you unplug early.

    I've been charging until the charger light does turn green and riding for ~1 mile before going down large slopes. So far the board has never actually turned over from over regeneration despite the warnings.

    I used to go exactly 1.8 miles before coming off 100% battery but that actually has increased to 2.9 miles. So I know my board is good for ~6 miles, from before this started, and now use the distance traveled to determine when I need a charge.

    When the weather gets cold, I will send the board back to FM but until it works great, just thinks the battery is charged for way too long. I've tried 24, 36, 48 and 72 hour charge cycles, no change. So I've just accepted it.

  • @skyman88 said in Over regeneration error - battery still at 100% after 11% usage:

    So I've just accepted it.

    That's it ! But I hope we get some words about it from FM...one day....
    @hafeedgood your english spoken is so dope bro ! 😂😂😂

  • this is a pretty straightforward software bug, given the symptoms. I believe it is literally some mundane math error, since I can use 100 - (% used - % regen) as a perfectly accurate gauge of remaining battery while the app continues to show 100% for miles. The app (or the board) could do that same math, and often does so correctly I presume, but somewhere a bug is breaking it for many of us. The good news is that means it will IMO be fixed with firmware at some point, even if FM never actually acknowledges the obvious bug here.

  • @readysetawesome That would be nice. I haven't contacted FM about this issue. Perhaps it will be escalated if we all reported this problem to them?

  • I have also run into this problem and FM wants me to send the board back. I've run it down to dead and then charged overnight, no luck. I was thinking of charging to 100% then disconnecting the wires from the control module where the BMS is, maybe it will re calibrate. Has anyone tried anything that works? This is super frustrating because I know it's a software problem and could easily be remedied.

  • Problem solved

    problem solved!

  • @vspot415 I tried disconnecting all the wires for a couple minutes, no luck.

  • Note that powering down the board resets the “usage” measurement so it won’t be accurate again until you charge all the way to green light.

  • The only way is to go off cell voltage, I know I'm dead at around 2.8v per cell

  • @readysetawesome really !? Thanks for the tip! I will try!

  • Bros for us slower learners here, what is it we learned? I'm not clear :) PS what is 'usage' showing?

  • @groovyruvy said in Over regeneration error - battery still at 100% after 11% usage:

    Bros for us slower learners here, what is it we learned? I'm not clear :) PS what is 'usage' showing?

    Learned to use cell voltage as "the truth" for remaining battery.

    I haven't seen what my usage bar looks like after riding but I need to start paying attention. Doesn't show up on the Apple Watch.... bummer.

  • @groovyruvy usage tells you how many % of your battery’s full charge have been consumed on this trip (since the board was switched on). Knowing this you can start with a fully charged board (ignore the app, wait for green light on on the charger), and as long as you don’t power off the board you know the battery will empty when usage reaches about 100%.

    I believe usage is a reflection of amp-hours flowing out of the battery, which the app is counting accurately (can be seen in the settings screen) but for some reason it isn’t applied to the battery gauge in the same way as the usage bar.

    (There may be a slight bonus from regeneration which you can also read in the app but that’s usually only 10% or less for me.)

  • This post is deleted!

  • @rk_d I doubt these issues are actively malicious. Chances are, there are bugs in the software, firmware, or hardware that they don't know how to track down and/or don't have a solution for. They are probably dragging their feet because they don't have a way to fix our boards, and the cost of completely replacing them is too high.

Log in to reply