Won't charge. Won't power up. Flashing...

  • @Rado I’m as frustrated as everyone else about this issue and I hope it gets resolved. But FM is not a monopoly, they were the first and they are still the best in this weird platypus of a niche market, but there are about a dozen cheaper knock-offs on Amazon “competing” with FM for the one-wheeled board market—they are just crap in comparison.
    The issue with FM is that they appear to be struggling to scale with their new-found popularity. They seem to have figured out how to scale production, they are no longer “building to order” but instead shipping right away which is GREAT. Now they need to scale support. It seems like there is quite literally one guy, sitting at a desk in California, answering a phone and responding to email, it’s not that one guy’s fault for getting overwhelmed. That doesn’t scale for a brand that is gaining popularity world-wide, especially when there is an apparent wide-spread issue like this.
    We paid a premium for these boards, so we are well within our right to expect solid customer service. We need to do what we can to make FM aware of the issue and how wide-spread it appears to be. And hope that they do right by us and scale their support to tend to our needs. As a relatively young brand, I don’t think they’ve given us a reason not to trust that they will do right by us, but this can also be seen as their first test.
    We shall see, but I for one am still hopeful.

  • Hi, I wanted to know step by step how you solved the issue, please! I'm having the same issue. Can you please outline?! Thanks!

  • I had this same issue - board would not turn on, but powered up and communicated via Bluetooth fine when plugged in, showed 00% charge, adapter light stayed green, would not charge.

    I tried a lot of different things, tried pushing power button while board was plugged in, did nothing. Tried removing access panel to get to battery wire harness, unplugged it, tried drying it out since it was wet outside, didn't work.

    Then I plugged the board in for 48 hours straight and then pushed the power button while the board was still plugged in, adapter flashed red momentarily, then battery power showed 100%. Board then powered on when unplugged with no issue. This is a strange one.

Log in to reply