XR constantly losing app connection?



  • @Khayman as I said..."which iPhone ...I use a X "(ten).

    I forgot these also work on Androids. But still a good idea to specify and see if anyone else is having problems with this specific combination. Don't assume because something works on one model, it will be flawless on another. Technology can be very finicky and unpredictable at times, and much of the electronics in the XR is different that the previous models.



  • @wheelrich said in XR constantly losing app connection?:

    I said..."which iPhone

    OH! So you mean I should start to read everything you said before I comment? Well I wouldn't be me if I did 😜
    Just kidding! I missed that part👍🏻sorry



  • @Khayman lol. No prob. I do that all the time myself, so I can't throw stones at you!



  • I have an iPhone 6s Plus that worked great with my OW+, and I have initial connection issues with my XR. Usually have to go through a solid 10-15 minutes of closing out the app, restarting bluetooth and restarting the board in no special order to finally get them to talk. Once connected it's solid, but sometimes I just say f' it and ride without the connection. Does anyone know what version of BT the XR uses? I think the 6s Plus is 4.1, so if the XR is a higher version it may be having problems clocking down?



  • I'm using android (Pixel 2), got no connection problems so far.



  • @jonnyk All Bluetooth versions since 5+ years ago should be fully backwards-compatible. That said, I just started having problems with my iPhone 7's connection to my XR yesterday. I was in the middle of a ride, and all my stats froze (battery level stopped dropping, mileage stuck). I had to force kill the app multiple times before it would connect.



  • @readysetawesome
    Yeah, I really question just how backwards compatible Bluetooth versions are sometimes. For instance, the bluetooth version in my car is pretty old because it's a 2012 model, any phone I've had that was natively 4.x bluetooth has had issues with the connection being buggy, even though it should work, same as BT headsets, and it's typically in the initial discovery, even though it was a previously paired device. Pain in the butt.



  • weak. it seems this bluetooth thing is a "latent bug" issue. Highly doubt FM can do anything about it. Sometimes it works, sometimes it doesn't.

    I can't imagine if this were the case w/ a boosted board where the bluetooth connection to the remote is critical. How would you stop if you suddenly lose connection? (I don't ride a boosted, but I'm guessing the board would just go neutral if it loses connection to the remote).

    But still, the connection on my ow+ is perfect and stays connected (as far as I can tell) the whole time. Whenever I look at my phone, I never see the reconnecting prompt (while I'm riding of course). For those of you w/ more than one board, can you confirm this?

    It's possible FM has chosen a choppy bluetooth chipset manufacturer or they've gotten sloppy at integrating the chip into their controller.



  • 20+ days and still no response from FM. It's still on my mind and I just found out there is a "Bluetooth connection" settings in the OW app. I didn't notice it at first because it's in the app settings when you're not connected to any board at the moment.

    The two settings under the Bluetooth connection section are 1) "Display connection issues" (appropriate for my situation) and 2) "Suppress when unused". Both settings appear to be turned off by default.

    Feel a little goofy for discovering something that was there the whole time. I'll have to break out the XR tomorrow and test it against these settings. Hopefully, I'll gain some insight and have PROOF the bluetooth connection is dropping and reconnecting.

    Anybody have experience with these settings?



  • As the developer of the OneWheelWear app, I am also experiencing disconnects from the board depending on the device being used. Fact is, that the Bluetooth antenna is sometimes not in the best spot or has a too poor performance in order to receive the board's signal at all times.

    The high number of different Android device manufacturers make this really challenging.
    I hope, that the antenna performance in newer devices will improve, since Bluetooth 5 has a higher range in the specification. So the antennas have to become better, anyways.



  • if anybody is curious, I tested my XR and + on a 5 mile track with the same phone. The XR easily drops and reconnects about 6-8 times while the + didn't drop once!

    Both rides lasted about 20 min. The phone is no further than my back pocket.

    On another note, a little disappointed how I see some people on the forum claim they have contacted FM for support and got serviced right away (typically by calling) while I've been waiting 27+ days on my ticket because I used email.

    I don't want to call FM via phone because I don't want to do to others what has happened to me: jump ahead of other customers that are still waiting for service.



  • I'm having the same problem. Two XRs. The Bluetooth connection on one won't work (the newer one with 20 miles on it) but the older one (pioneer board with 250 miles) works just fine. If I can get it to connect it won't show any data in real time. It just keeps dropping the connection.



  • @Rado Out of curiosity, what type of phone are you trying to connect?



  • @skyman88 iPhone 6S. My V1 also connected fine.



  • My iPhone 8+ always has to reconnect to my xr while riding. It may connect briefly and update battery but I barely ever get to see speed or other data.



  • @Rado and @andematt would you guys mind disclosing when you purchased your XRs and what is the current hardware version? (look it up in the app under board settings).

    @Rado you mentioned you have two XRs. Could you check if the hardware versions are the same on both? Does the older one work fine because it happens to have a different hardware version than the newer one?

    mine: purchased July 2018 w/ hardware version: 4208



  • @suboba yes, my XRs have different hardware and firmware versions. One is the pioneer version and the other is a new one.



  • I, too am experiencing connection drops while riding.

    If I just turn my board on and let it sit there—it immediately connects to my app and stays connected without a single issue. It will stay connected until I walk about 10-15 feet away.

    It does drop though when I turn my back to the board and I’m right next to the board (putting my body between the board and my phone)

    It drops constantly while riding. It is disconnected more than it is connected. I think my foot must be over the antenna in the board.

    iPhone 7 Plus
    iOS: 11.4.1
    Onewheel XR
    Hardware: 4208
    Firmware: Andromeda - 4117

    Can someone confirm where the Bluetooth antenna is in the XR? Like specific location, not general location. Pictures would be even better.

    I think the Bluetooth chip in the board is super-weak. For comparison—I can walk across my house (100+ feet), with walls, appliances, etc between my phone and my Apple Watch Series 3 or my AirPods and I keep my Bluetooth connection perfectly fine with my phone.

    I wonder—does goofy vs regular matter? Those who are having problems; what is your riding style? I’m goofy.
    Also, people having problems; do you have float plates? I do. Finally, do you have a handle on your board? If so, which side? (when looking at your board from the back)
    Our feet and/or aftermarket parts may be insulating the already weak/underpowered antenna.

    Hopefully it is a power issue—that is something a firmware update may be able to fix (allow more power to be fed to the Bluetooth on the board to increase its reliability/range). If it’s a limitation of the hardware—these would all need to be sent in to have the chip/antenna replaced.



  • @eckit I think it has to to with the actual Bluetooth chip and controller board. I have two XRs. They have different hardware and firmware versions. One works fine and the other won't stay connected.



  • @Rado ok, those are two variables; hardware and firmware? If so, we can’t rule if it’s one or both deltas.

    That said, would you mind sharing?

    Ride Style (regular/goofy):

    Phone Location While Riding (front of body/back of body):

    Float Pads (yes/no):

    Hardware Version (of the affected board):

    Firmware Version (of the affected board):

    I’m interested in seeing if there is a trend with anything from all of us.


Log in to reply