XR constantly losing app connection?



  • I have a Galaxy S9 plus and have been toying with it losing connection and after resetting my BT connection on the phone and downloading Gemini and I keep my phone on my fender in an old case with velcro in front of my BT speaker and have not lost connection yet 0_1542597357476_20181118_181125 (1).jpg



  • Here is my update after installing Gemini. First couple days riding and playing inside the house connection was perfect. Yesterday and today the weather was great so I had a 2hrs rides on both days and unfortunately, connection got lost right after I left the house and it was very difficult to connect even when I kept iPhone near the pad. I tried again inside the house and connection is perfect... GO FIGURE!!!!
    So the verdict is - Gemini didn't help my board and I will be sending it for repair.



  • Doesn't seem like anyone's reporting a reliable fix from FM.



  • @tlamb2 That seems incredibly impractical. I don't think I'm sending mine in. Unless FM is using new BT chips or antennas I suspect there's only a stop gap solution until the next version of the OW. Would be helpful if they just came forward and stated the problem and solution. Also kinda BS that once you're outside your warranty this issue wouldn't be covered even though it's a manufacturing defect.



  • Following up with my previous comment, it only worked because I was using my watch and the phone was near the board. It still disconnects. Maybe it’s less frequent, I didn’t count, but it’s dangerous to try messing with it while riding so I’ve basically given up on using the app.

    It’s a shame, they have this killer advanced product and then let something simple but critical go



  • Does anyone have this issue that doesn't a fender kit? Mine is on the verge but stable without one. Also, has anyone tried taking off the fender kit to see if it changes anything.



  • @Fresh same for me before and after installing my fender.



  • I got have the same problem with a Brand new board with the iPhone 7 Plus. I updated the iPhone 7 Plus with the new firmware and that did not solve it. I updated the app and the board’s firmware that did not solve it. When it sits there on it stays connected one i mount the board and/or ride it its starts to lose connection and tries to reconnect and sometimes it does but the app doesn’t update. Ie: speed shows what it was when it was disconnected. I have no accessories and power is good on both. Not sure what it’s the issue.



  • @Future-Motion what is going on? You know what the issue is as you are taking boards in for repair, so why are they still going out with this problem? (my feeble attempt to get FM to respond)



  • @kd6tav When did you get your board? I had this problem from the beginning and I got mine in August... and I got the shipping labels in October. The weather turned wintery here so I'm sending mine for repair early next week... but I have the same question: Why do still sell them with this known BT connection issue.



  • @Jackalope Maybe they don’t even have a fix for it yet. Reading through this thread I don’t see any that have gone in for repair and come back fixed.



  • @Rado That’s my concern. Having to strip it and ship it multiple times. I will get mine back to FM soon and will report back the outcome ASAP.



  • @MotoGPTy That would be great. I’m still debating whether to send it in yet or not. I want to know that they can actually fix it.



  • I have reasonably good news for all of you fine people here.

    I finally got around to testing my onewheel that came back from FM last week (work has been insane). I'm happy to report it's FIXED!!!!! Mostly.

    The issue I was having was that it would lose connection to my phone unless I had my phone down by my shin. It completely disconnected once in my pocket. It connected fine while plugged in, but as soon as it was moving, the connection was awful.

    Now that it's been returned, the behavior is this:

    • 100% strong connection while holding my phone in my hand (iPhone Xs 12.1) I was able to move it up to face height and maintain a strong connection
    • Slightly worse connection while in my front pocket. My apple watch never showed a disconnect, but the current speed would freeze and unfreeze occasionally.

    This feels like an acceptable level of functionality for me at this point, and I'm pretty happy that my phone maintains its connection now.

    Things of note:

    • Odometer has been reset (I only had 12 miles on it, so not really a problem, but people with more miles may get it reset and it will technically be inaccurate going forward)
    • Firmware and hardware revision numbers are the same
    • I have not updated the firmware or my phone app for the new Gemini update because I wanted to test the changes with no other changing variables. I will probably do that later today.
    • I tested with no fender installed. I'm going to add my fender hopefully today as well.

    Edit: tested with official fender still maintains solid connection outside riding around my apartment's parking lot. Updating to Gemini now and heading out to another parking lot.

    Edit2: Tested with Gemini firmware. Connection still solid. Got a footpad warning notification on my watch, so there's at least some connection while my phone's in my pocket, even if it's not perfect.



  • @gsparx Thanks for the info! This supports the fact that @Future-Motion has a solution, yet still aren't shipping new products with the fix. Keep us posted on the ongoing testing!



  • Thanks @gsparx - Perfect!!! I assume you did your tests outside. My connection is quite good inside the house but outside - very, very bad.



  • @Jackalope Yep, riding around in the apartment parking lot



  • @Jackalope i got mine November 1. Mine connection works if i hold my phone at my knee, right over the front of the board.



  • @gsparx Thanks for the update. I'm not going to send mine in. I keep my phone in my backpack and it seems like even with this fix it will disconnect.



  • @christian I'm confused, it sounds like his issue is fixed?