XR constantly losing app connection?



  • @Future-Motion what is going on? You know what the issue is as you are taking boards in for repair, so why are they still going out with this problem? (my feeble attempt to get FM to respond)



  • @kd6tav When did you get your board? I had this problem from the beginning and I got mine in August... and I got the shipping labels in October. The weather turned wintery here so I'm sending mine for repair early next week... but I have the same question: Why do still sell them with this known BT connection issue.



  • @Jackalope Maybe they don’t even have a fix for it yet. Reading through this thread I don’t see any that have gone in for repair and come back fixed.



  • @Rado That’s my concern. Having to strip it and ship it multiple times. I will get mine back to FM soon and will report back the outcome ASAP.



  • @MotoGPTy That would be great. I’m still debating whether to send it in yet or not. I want to know that they can actually fix it.



  • I have reasonably good news for all of you fine people here.

    I finally got around to testing my onewheel that came back from FM last week (work has been insane). I'm happy to report it's FIXED!!!!! Mostly.

    The issue I was having was that it would lose connection to my phone unless I had my phone down by my shin. It completely disconnected once in my pocket. It connected fine while plugged in, but as soon as it was moving, the connection was awful.

    Now that it's been returned, the behavior is this:

    • 100% strong connection while holding my phone in my hand (iPhone Xs 12.1) I was able to move it up to face height and maintain a strong connection
    • Slightly worse connection while in my front pocket. My apple watch never showed a disconnect, but the current speed would freeze and unfreeze occasionally.

    This feels like an acceptable level of functionality for me at this point, and I'm pretty happy that my phone maintains its connection now.

    Things of note:

    • Odometer has been reset (I only had 12 miles on it, so not really a problem, but people with more miles may get it reset and it will technically be inaccurate going forward)
    • Firmware and hardware revision numbers are the same
    • I have not updated the firmware or my phone app for the new Gemini update because I wanted to test the changes with no other changing variables. I will probably do that later today.
    • I tested with no fender installed. I'm going to add my fender hopefully today as well.

    Edit: tested with official fender still maintains solid connection outside riding around my apartment's parking lot. Updating to Gemini now and heading out to another parking lot.

    Edit2: Tested with Gemini firmware. Connection still solid. Got a footpad warning notification on my watch, so there's at least some connection while my phone's in my pocket, even if it's not perfect.



  • @gsparx Thanks for the info! This supports the fact that @Future-Motion has a solution, yet still aren't shipping new products with the fix. Keep us posted on the ongoing testing!



  • Thanks @gsparx - Perfect!!! I assume you did your tests outside. My connection is quite good inside the house but outside - very, very bad.



  • @Jackalope Yep, riding around in the apartment parking lot



  • @Jackalope i got mine November 1. Mine connection works if i hold my phone at my knee, right over the front of the board.



  • @gsparx Thanks for the update. I'm not going to send mine in. I keep my phone in my backpack and it seems like even with this fix it will disconnect.



  • @christian I'm confused, it sounds like his issue is fixed?



  • @MotoGPTy If the connection is spotty in his front pocket (mine is currently like that), I don't think the connection is going to be solid with my phone in my backpack. For me to send my board in, I'd want a solid BT connection regardless of where my phone is on my person. That's just me though - I don't ride around with my phone in my hand.



  • @gsparx i wonder what they did, just change it out for another modular or an upgrade....



  • I'm having this same issue.

    This was taking with me just standing on the board with the phone in my hand (back foot down, no major pressure on front plate)

    alt text

    While riding, almost no connection at all - I would say it's connected about 5% of the time.

    I've sent a request into the onewheel support about a week ago, but no dice with responses yet:(



  • @Unsu They’ll send you standard instructions for sending the board back when they do get back with you.



  • Yea my board doesn't stay connected for more than 5 seconds at a time. iPhone XS, brand new board with 24 miles on it. Can't use Float App either because of bluetooth connectivity issues. Have to be sitting next to my board for it to be reliable



  • I have a new XR, just received it a week ago. Hardware 4208. I have the same issue everyone here is having. I contacted support and they said I can send it back and they will fix as long as the board falls under the warranty. It should, it only has about 7miles on it. They did recommend keeping it for a few weeks to enjoy during the holidays and then send it back. It was highly encouraged to do this. Which makes me wonder on if they are still looking to correct the issue or they are just extremely busy with issues and the holidays. One thing I am discouraged on is I have to pay shipping both ways. I just bought this and now have to spend another $100+ to have it fixed with only 7 miles on it... I can maybe seeing paying shipping one way but not both. I do love the board but not happy with the service so far. I will wait to send back.. Really want to play with it during the holidays and don’t want to spend the extra cash on it.

    IPhone: 12.0.1
    Onewheel: XR
    Hardware: 4208



  • @sparkspnt There is no way you should pay shipping. I reported the same thing on my XR that I received in Oct. I called them after reporting it (same as you, maybe 15 miles on it) since they didn't reply within a couple of days. After talking to Jon in support, I got an email that he would send me the labels to return it. Unfortunately, I can't send it back until March as it's at my vacation home, but he said no problem to let him know at that time and he'll send the labels then. It's a defect in the board, they have to replace a component in the controller, so covered by warranty.

    Good luck!



  • This was part of the email:

    Once the board arrives it will be diagnosed and evaluated. We will of course fix any issue free of charge if they are caused by manufacturing issues. If your board passes our technicians’ evaluation, please note we will ask you to cover the shipping costs. Anything outside the scope of warranty will be quoted for your approval. Our team will do our absolute best to make sure you are informed along the way. You will receive a tracking number once the board is making its way home.