XR constantly losing app connection?



  • @readysetawesome
    Yeah, I really question just how backwards compatible Bluetooth versions are sometimes. For instance, the bluetooth version in my car is pretty old because it's a 2012 model, any phone I've had that was natively 4.x bluetooth has had issues with the connection being buggy, even though it should work, same as BT headsets, and it's typically in the initial discovery, even though it was a previously paired device. Pain in the butt.



  • weak. it seems this bluetooth thing is a "latent bug" issue. Highly doubt FM can do anything about it. Sometimes it works, sometimes it doesn't.

    I can't imagine if this were the case w/ a boosted board where the bluetooth connection to the remote is critical. How would you stop if you suddenly lose connection? (I don't ride a boosted, but I'm guessing the board would just go neutral if it loses connection to the remote).

    But still, the connection on my ow+ is perfect and stays connected (as far as I can tell) the whole time. Whenever I look at my phone, I never see the reconnecting prompt (while I'm riding of course). For those of you w/ more than one board, can you confirm this?

    It's possible FM has chosen a choppy bluetooth chipset manufacturer or they've gotten sloppy at integrating the chip into their controller.



  • 20+ days and still no response from FM. It's still on my mind and I just found out there is a "Bluetooth connection" settings in the OW app. I didn't notice it at first because it's in the app settings when you're not connected to any board at the moment.

    The two settings under the Bluetooth connection section are 1) "Display connection issues" (appropriate for my situation) and 2) "Suppress when unused". Both settings appear to be turned off by default.

    Feel a little goofy for discovering something that was there the whole time. I'll have to break out the XR tomorrow and test it against these settings. Hopefully, I'll gain some insight and have PROOF the bluetooth connection is dropping and reconnecting.

    Anybody have experience with these settings?



  • As the developer of the OneWheelWear app, I am also experiencing disconnects from the board depending on the device being used. Fact is, that the Bluetooth antenna is sometimes not in the best spot or has a too poor performance in order to receive the board's signal at all times.

    The high number of different Android device manufacturers make this really challenging.
    I hope, that the antenna performance in newer devices will improve, since Bluetooth 5 has a higher range in the specification. So the antennas have to become better, anyways.



  • if anybody is curious, I tested my XR and + on a 5 mile track with the same phone. The XR easily drops and reconnects about 6-8 times while the + didn't drop once!

    Both rides lasted about 20 min. The phone is no further than my back pocket.

    On another note, a little disappointed how I see some people on the forum claim they have contacted FM for support and got serviced right away (typically by calling) while I've been waiting 27+ days on my ticket because I used email.

    I don't want to call FM via phone because I don't want to do to others what has happened to me: jump ahead of other customers that are still waiting for service.



  • I'm having the same problem. Two XRs. The Bluetooth connection on one won't work (the newer one with 20 miles on it) but the older one (pioneer board with 250 miles) works just fine. If I can get it to connect it won't show any data in real time. It just keeps dropping the connection.



  • @Rado Out of curiosity, what type of phone are you trying to connect?



  • @skyman88 iPhone 6S. My V1 also connected fine.



  • My iPhone 8+ always has to reconnect to my xr while riding. It may connect briefly and update battery but I barely ever get to see speed or other data.



  • @Rado and @andematt would you guys mind disclosing when you purchased your XRs and what is the current hardware version? (look it up in the app under board settings).

    @Rado you mentioned you have two XRs. Could you check if the hardware versions are the same on both? Does the older one work fine because it happens to have a different hardware version than the newer one?

    mine: purchased July 2018 w/ hardware version: 4208



  • @suboba yes, my XRs have different hardware and firmware versions. One is the pioneer version and the other is a new one.



  • I, too am experiencing connection drops while riding.

    If I just turn my board on and let it sit there—it immediately connects to my app and stays connected without a single issue. It will stay connected until I walk about 10-15 feet away.

    It does drop though when I turn my back to the board and I’m right next to the board (putting my body between the board and my phone)

    It drops constantly while riding. It is disconnected more than it is connected. I think my foot must be over the antenna in the board.

    iPhone 7 Plus
    iOS: 11.4.1
    Onewheel XR
    Hardware: 4208
    Firmware: Andromeda - 4117

    Can someone confirm where the Bluetooth antenna is in the XR? Like specific location, not general location. Pictures would be even better.

    I think the Bluetooth chip in the board is super-weak. For comparison—I can walk across my house (100+ feet), with walls, appliances, etc between my phone and my Apple Watch Series 3 or my AirPods and I keep my Bluetooth connection perfectly fine with my phone.

    I wonder—does goofy vs regular matter? Those who are having problems; what is your riding style? I’m goofy.
    Also, people having problems; do you have float plates? I do. Finally, do you have a handle on your board? If so, which side? (when looking at your board from the back)
    Our feet and/or aftermarket parts may be insulating the already weak/underpowered antenna.

    Hopefully it is a power issue—that is something a firmware update may be able to fix (allow more power to be fed to the Bluetooth on the board to increase its reliability/range). If it’s a limitation of the hardware—these would all need to be sent in to have the chip/antenna replaced.



  • @eckit I think it has to to with the actual Bluetooth chip and controller board. I have two XRs. They have different hardware and firmware versions. One works fine and the other won't stay connected.



  • @Rado ok, those are two variables; hardware and firmware? If so, we can’t rule if it’s one or both deltas.

    That said, would you mind sharing?

    Ride Style (regular/goofy):

    Phone Location While Riding (front of body/back of body):

    Float Pads (yes/no):

    Hardware Version (of the affected board):

    Firmware Version (of the affected board):

    I’m interested in seeing if there is a trend with anything from all of us.



  • I have no idea what's going on here. Today, I ride my board on the same track for 6 miles for about 20 min and surprisingly, not a single disconnect. Then, I stop for a while to look at my phone and sure enough, connection is lost and 'reconnecting' appears on the screen. I wasn't even in motion. I just stopped to look at the app and boom - disconnected while just looking at it! After that point, it started dropping and reconnecting on a regular basis for the next half hour. Easily 5 to 6 times about 5 - 7 minutes apart.

    For me, this is really an intermittent bug. I'm afraid that if I send it in to FM, the connection will be solid while they test it and say there's nothing wrong with it. But, when I get it back, sure enough it will drop on me.

    My connection sometimes drops right at the beginning and sometimes not until an hour later! However, I still think the connection should never drop unless you go out of range, ow is powered off or phone is off. My OW+ has NEVER dropped.

    @eckit for what it's worth:
    ride style: goofy
    phone location: both! sometimes I wear a jacket with a front breast pocket. Other times, it's in my back pocket.
    float pads: no
    hardware v: 4208
    firmware v: 4117 - andromeda
    purchased: July 2018

    I really do think it's a bad bluetooth chipset they have. It's possible they changed it and went with a cheaper chipset at a cost of performance. It's possible they haven't changed the chipset, but their hardware change has somehow affected it. Without a doubt, hardware version 4208 disables CnR. Maybe the circuitry they put in has somehow affected the bluetooth? Maybe it's just a bad production batch?

    It's really scary to think about firmware updates with this issue. Knowing that the bluetooth connection is choppy and could drop at any time, you could easily brick if you tried updating your board's firmware and the connection dropped!



  • @suboba thanks for the info. We have the same hardware and firmware and we both ride goofy, so that’s good to know. I’m interested to see if any of these factors continue to be consistent as more people respond.

    As far as bricking the board during a firmware update; my board has never dropped if I keep my phone within 2 feet or so. If/when a firmware update is available, I plan on just sitting my phone right on the board while it updates.

    I went riding yesterday and slipped my phone in my right (forward) boot leg. Yeah—I wear cowboy boots while I ride. :) The phone and board stayed connected the entire time, I know this because I checked my watch while riding and it never lost connection.

    From this; it sounds like the Bluetooth is constantly engaged on the board—it is simply a range issue. As opposed to the Bluetooth on the board actually cutting out/dropping due to loose connections or some other reason.



  • @eckit

    Old XR
    Hardware - 4206
    Firmware - Andromeda - 4107
    Works fine. Stable Bluetooth connection

    New XR
    Hardware - 4208
    Firmware - Andromeda - 4117
    Poor Bluetooth connection. Won't stay connected or show realtime info

    I ride regular. Phone usually in front pocket.

    The connection problems also show themselves in the OWheelBuddy and Float Deck apps which leads me to believe it is not a problem with the official OW app.



  • Exactly same situation for me.
    Old XR : stable bluetooth
    NEW XR with new hardware and firmware : keeps reconnecting
    Use iPhone 6s with iOS 10.



  • @Rado thanks for the info. I plan on letting this ride for a week. Then compile all the results and send to FM support. Hopefully there’ll be enough of us to get them to address it. I for one wouldn’t mind helping out with any beta testing if their software engineers have any ideas on how to improve range without a change to the physical chipset.



  • @CLBR thanks for the info!