XR constantly losing app connection?



  • @tomfoolery the bluetooth module soldered on the controller board is almost touching the metal plate that closes the box, that blocks the RF (it is surprising that it still works).

    An external antenna is possible and I guess it will increase range and reliability enormously. (can be a 1/4 wavelength sized small piece of wire)



  • I would like a better quality picture of the board to have an idea on the easiest way to connect the antenna

    Modern iPhone or hi-end Android with good lighting is good, focused on the bluetooth module (where it says ILT245s)



  • I started putting my phone in a jacket chest pocket or a jacket side pocket, instead of my jeans pocket, and my signal works all the time when I’m riding. As phone stays connected, my Apple Watch app also stays connected. If I put phone back in my jeans it loses connection as soon as I start riding.



  • Googling for that BT chip yields some interesting results. Other products using it have issues, too. Also found a pin out schematic — apparently the first pin is the antenna if someone with a soldering iron wants to play around?



  • Ok, FM replied on my ticket. I can send the board back for the Bluetooth repair. If its under warranty it is on their expenses. If not, I have to pay. If they can't find anything, shipment costs are on me.
    Since this appears to be a common error and I have it since the day I got the board, I cant's see why it would not be covered by warranty. But, shipping it from Europe to USA and back, is a big cost if they would claim there was nothing wrong or it was not under warranty. Anyone experience with this?
    And any problems with taxes or duties when zending back to Europe? (I have an invoice that can prove I bought the wheel in Belgium)



  • @gsparx they did not charge anything? You live in the USA? I want to ship mine from Europe, but if they would claim there is no problem with BT or it's not under warranty, (shipping) cost are on me... How long did it take to send in and return your board?



  • I also am having same connectivity problem. Brand new XR with updated firmware. Disconnects as soon as I put my phone in my pocket!



  • @Diceman Yes, exactly the same issue as i have. My board is at FM right now and is currently in the repair queue. Soon i will know if they wil fix it under warranty. (I can't imagine they won't)



  • @JH Looking forward to hearing from you once the board is returned. I still haven't heard any success stories and have been following this thread for months. (...admittedly, I could have missed one) Thanks!



  • @MotoGPTy I sent in my XR to have the Bluetooth issue fixed under warranty. I didn’t pay anything. It is improved but not as good as my V1 or Plus.



  • I'm about to send mine back. Will be under warranty they said. I heard of quite a few people who had their board back and it works very good after.



  • @kanguru007 Here is the user manual for that Bluetooth module. It’s probably worth a look at. ILT254S: https://fccid.io/2AAXH-ILT254/User-Manual/User-manual-2126527

    It does have an external antenna pin on pin one of the PCB module. Not sure if it needs to be turned on to use it. I just sent my board in to “fix” it. I’ll see if it gets any better before trying this myself. I work with RF electronics so doing a little micro soldering is not a big deal for me, but I would doubt anybody can do this with out the right tools.



  • I just sent mine in yesterday. They say turn around is 2 weeks I hope so and hope they fix it. I figured with all the rain we are getting here in SoCal it is the perfect time to send in I will post the results when it is returned



  • Just got my Xr back from FM to fix the Bluetooth issue. Tested it for few minutes; looks like it works fine now.



  • I just got mine back. The signal strength seems to have a marginally improved. It held connection for about a minute into the ride then dropped. Still not usable.



  • @CLBR No, I'm riding bareback with no changes from the stock configuration.



  • I just got my board back from @future-motion and it seems like the BT issue is fixed. It connects super fast and I just went for a nice session and it stayed connected the whole ride with phone in my back pocket. The board came back with my miles still showing so I guess the main controller was not switched out. All I know is it works now like it is suppose to Thanks @future-motion for the quick turn around 11 days total from shipping to return Thanks, Thomas



  • @rfkilowatt @kanguru007 I'm in Argentina so sending to USA is no-way (customs cost as hi as U$S 1000 here).
    I'm electronic engineer and I have the right tools, maybe I will try to solder an external antenna (1/4 lambda). What do you think?



  • @tlamb2 THIS!
    It really works better! I was thinking in opening the board and soldering an external antenna, but this works! I've to test it more time, but great so far!

    You've to enter "Developer Mode" in Android.
    Go to Settings > System Info (the last on the list), then tap 7 times on the Build Number field (also the last field).
    Then go search in settings, and look for AVRCP, then switch to 1.6 as @tlamb2 says.

    That's it!



  • @gasppol Plus it also helps to clear your bluetooth settings in an android phone it seems to get rid of all the old Bluetooth connections making current connections better. In my work van now I am able to see text messages delivered via bluetooth to the vans audio unit which it use to do but suddenly stopped but after resetting my bluetooth that works now also. So it does something.


Log in to reply