XR constantly losing app connection?



  • FOR WHAT IT'S WORTH....Possible alternate fix. My 08 hardware XR, like many others, has been very bad connecting to to my iPhone since I first got it. It disconnects continually while I am riding, making it almost useless. As I have said many times, my first XR, an 06 model, has worked flawlessly from day one.

    So, recently I change my tire to a treaded Burris. Now, here is where it gets very unclear about what fixed my problem. I was very careful with removal of the Vega tire, and the wires that needed disconnecting, etc. I had heard some horror stories from a few whose boards did not work right after changing their tires. I cleaned everything as I went along. While I had the board all apart, I decided to install my brand new aluminum flight guard plates, as I was putting everything back together (previously had float plates on). The board works fine....plus... as long as I am right by the board or riding it, now my iPhone AND Apple Watch stay connected!!!! I have ridden it at least 4 times since the tire change, and it seems to be consistently working.

    I have 2 theories: 1) in disconnecting and reconnecting the cables, (which were a bit difficult to remove, but snap locked into place when reattached), I corrected a poor connection to the control board, which allowed a stronger bluetooth signal. 2) the new flight guards, from flight fins, being metal (heavy gauge aluminum) are reflecting the bluetooth signal and acting like an analog amplifier.

    I am not sure which is the case, but my guess is that number 2 is the most likely reason.



  • @someoneingermany
    i bought my xr from germany too.i am from Rome,Italy.i had the bluetooth issue from the beginning,weak connection.
    after one month i contacted FM and they aknowledged the issue and proposed the ship of all the board.
    they even created a ticket for the expedition (the cost of such expedition is about 250 eu)
    but i preferred to send only the control board.easy to disassemble.
    all the operation in about 2 weeks.now i have the new hardware control board.
    the connection now is finally stable and i can also use my smartwatch onewheel app ,very nice indeed.
    so for my experience i must give a big up to Future Motion.
    is not easy to manage a service in europe from the u.s.a.
    a compromise is necessary, i think.
    anyway i hope they will open an official service here in europe.
    this will be the perfect solution



  • @tartax Did you pay for the shipping or did they? Was it through FedEx or another carrier? Good to hear you had a good experience.



  • @someoneingermany
    i didn't pay nothing and yes,it was with fedex.



  • @tartax how far away from a FedEx store do you live? I'm guessing there is one in Rome as it's the capital?



  • @someoneingermany of course ,i live in the capital city and the courier came directly to my house.after fm created the ticket i contacted the fedex office and they arranged everything .



  • @tartax yeah, that's how it should be. Unfortunately, if you live far away from a FedEx office they are reluctant to help with shipping at all.



  • @someoneingermany "under warranty" was the operative phrase: they often find water damage and the like which precludes repair under warranty and thus transport at owner's cost. just sending the module will help a lot with shipping



  • @ooww water damage and "the like"? What else could they find that would void the warranty?



  • @someoneingermany I read about FM denying warranty because of "mechanical damage"



  • @ooww huh, interesting. I'd be surprised if they found that on the controller module.



  • I just got my XR back from FM. Bluetooth seems to be working now. They said "Hope you are well. I wanted to report that your board has completed repairs and it will be tracking towards you. The techs identified the root of the issue and replaced your board's controller circuit board under warranty and free of cost."

    Only thing is it still says version 4208! The bluetooth still says reconnecting a couple of times per ride, but it's better than before. Perhaps only a certain percentage of version 4208s are defective?

    I'm really curious if someone with a 4209 can open it up and we can see what design change they made to the printed circuit board.

    Small detail - my board's name and ID number in the app didn't change. The odometer did reset to 0 though. I'm wondering if they actually swapped it.



  • @Jackalope what hardware version did they replace yours with?



  • @wheelrich STILL WORKING! Did 10 miles this morning at Cal State. The app, both thru my iPhone and the Apple Watch is still staying connected, as long as I am within a few feet of the activated board. When I walk away it disconnects, but comes back as soon as I return.

    As I said a few weeks ago...the things I have done different, since it started working consistently, are 1) installed a Burris treaded tire, and 2) added the heavy duty aluminum float plates.

    I thot this was going to be another fluke (like when I added an OW Apple Watch complication....that didn't last), but this seems to be consistent for 3 different rides at 2 different locations. And the first location had terrible wifi.

    Again, my guess is the aluminum plates have acted as a reflector for the blue tooth signal. Just a guess. So I will not be sending in my board for the mad scientists at FM labs to tear apart, at least not yet.



  • So here's an update on my repair process. 84 days after I opened the ticket, my wheel is finally working again. This has been a total catastrophe and I hope never to have to deal with them again.

    The communication during the entire process has been horrible. It was slow and disorganised. They didn't properly read my messages and I had to repeat myself multiple times. Due to my "special case" (them refusing to ship because of distance from FedEx shop) there were three people involved (one of which the Chief Operational Officer), and at some points I felt like they were not talking to each other.

    Once the wheel arrived at their HQ it took them about two weeks to repair and then ship it off again. I was told they would simply "inspect it and send a new one out" but that wasn't the case. When It was returned, the casing for the controller module was dented in some places, especially on one of the edges. I am worried it will let in more dust now. Also the threads in three of the screw holes are already bad after opening it once. Three screws aren't properly fastened anymore. This is something I've heard others complain about as well.

    For those interested, the milage data was not wiped. Everything is as it was when I sent it out. And Bluetooth works amazingly well. I can walk away a couple meters without losing signal and it never seems to disconnect while riding.

    I'm happy to be back on my wheel and I hope it doesn't fall apart or stop working anytime soon.



  • @someoneingermany I had the bluetooth issue repaired on my XR, and while I didn't have the long wait like you did, I did get mine back with a totally separated bolt in the front bumper. I called them up and told them I've never taken it apart, so they had me take a picture. A new front bumper was sent my way and I replaced it within days.

    If you have broken, stripped, or missing screws or parts, give them a call, nothing to lose.



  • @OneDan They suggested I glue it together. 🤷‍♂️


Log in to reply