XR constantly losing app connection?



  • So after some back and forth with FM support I was told to download an app called “Light Blue” and check the Bluetooth connection by placing my phone directly on the front footpad and take a screenshot and then while holding the phone as if I was riding and take a screenshot. I think the app they are referring to is actually called “LightBlue Explorer” as “Light Blue” doesn’t appear to have anything to do with Bluetooth. I will try this with both my XRs and report back my findings here. Maybe some of you can do the same?



  • +1

    New XR (less than week old)
    Hardware - 4208
    Firmware - Andromeda - 4117
    iOS: 12 on 7+

    BT disconnects often, but rides are fragmented almost always unless the app is open/running and screen not locked. In other words, rides are cut short even when I don't get a notice that the board has disconnected from the app. Have tried w. different location settings, with light on/off, still drops ride/gps data.



  • @Rado thanks for the update! Will do the same.



  • I did use the app, dB varies a lot but the best I could get was around -76, at waist height.



  • @CLBR Yeah, I tried it with both my XRs and they were pretty much the same. Fluctuating between -70 and -85. I’m not sure what this helps with. I was hoping it would show a drastic difference between the two but it didn’t.



  • I just upgraded my iPhone X with iOS 12 yesterday and oddly i have not had ANY disconnects and the connection to the board is almost immediate. It's a similar experience with my Samsung S8+ that connects almost immediately. Has anyone else noticed this after updating to iOS 12? In iOS 11.4 I was having all kinds of disconnects and drops...

    I will say that I'm still getting a footpad sensor warning while riding and have yet to hear back from FM support on this...



  • @bakemono with your iPhone update, what was your test case? That is, for how long, how many miles, etc... Like I said in an earlier post, one random day, I rode for about 5 miles in about 30 min without a single disconnect. A short while after that, it started raining disconnects.

    Idk. It's a very intermittent bug. Very difficult to reproduce.



  • @suboba yeah its fast to connect now but it still doesn't stay connected. I noticed this while riding today. Also LightBlue no longer shows the one wheel as a BT source so I can't get the reading any longer.

    Back to the drawing board :/



  • @bakemono I updated my iPhone from iOS 10 straight to ios12 and didn’t notice any difference, still had the same reconnection issues ...



  • For those who have it working ... what is your typical range ?
    Phone needs to be in your front pocket only and disconnects happen when it’s a bit more far away ? Or it works everywhere ?



  • @CLBR said in XR constantly losing app connection?:

    .. what is your typical range ?
    Phone needs to be in your front pocket only and disconnects happen when it’s a bit more far away ? Or it works everywhere ?

    I don't want to believe that the distance between the phone and the board should be a factor. Do Boosted riders need to hold their remote close to the board in order to maintain a solid connection? I highly doubt it. (in fact, would be kinda of dangerous if they experienced such disconnects for obvious reasons).

    Front pocket, back pocket, breast pocket, front shoe, back shoe... it really shouldn't matter. The signal should be omnidirectional for at least 5 feet. My OW+'s connection is solid no matter where I put my phone!

    But yes, calling all owners that have an XR w/ hardware v: 4208 and firmware: 4117, Can any of you say you are experiencing a stable connection?

    If a subset of XR owners with the mentioned versions are not having any connection issues, that could mean there was a bad production batch which some of us unfortunately received.



  • Hi,

    Same issues here...

    New XR
    Hardware: 4208
    Firmware: andromeda 4117
    iOS 12 on iPhone X

    I hope FM will be able to fix it by firmware update.



  • Hey all. Another factor to ask is are you also connected to a smart watch. I don’t know if this will interfere with the connection to the board but I use a Bluetooth speaker at work and for a while I could control the music via watch. Then one day I had problems just connecting my phone to the speaker. I tried forgetting the Bluetooth connection and restarting the phone and re-pairing my devices. It took a couple tries of that before everything worked fine again. Just a thought.



  • Same issue here. I have an iPhone 7 and was using iOS 11.4.1 with the phone in a small shoulder bag that rides in front. Board is newish One+ XR, no kick plates. Loses connection constantly while riding but is fine when stationary. Hardward: 4208, Firmware: Andromeda 4117



  • Hi there,

    same thing with me:
    New XR
    Hardware: 4208
    Firmware: andromeda 4117
    iOS 12 on iPhone X

    Please help!



  • I’ve reached out to FM Customer service. Provided a link to this thread in addition to some of my own findings (which I already posted here).

    I will let y’all know what they say. I fully expect to have to follow up with a phone call this coming week based off of other’s comments.

    In the meantime, if you’re fortunate enough to have an iPhone and an Apple Watch; you can put your phone in one of those sport armbands and strap it to your front calf. Then, use your Apple Watch to monitor your range, speed, battery level, etc.

    I wear cowboy boots, and I just shove my phone in the neck of my front boot. My phone NEVER loses connection while it’s in my boot. And I monitor my board from my Apple Watch.

    This should only need to be a temporary bandaid, of course. FM should provide a more practical and permanent solution.



  • @eckit I hope FM doesn't get us all mixed up. I'm getting close to sending in my board (after almost 2 months after I started this thread!). The customer service rep is getting things ready for me.

    Of course with all the reference to this thread, I hope they don't get mixed up with who they're talking to. eg. Did I speak with you on the phone? forum? email? ticket? etc...

    This thread is HOT! Enough people have reported this problem. Isn't this enough to warrant a recall?

    I'm gonna go ahead and say it. Hardware upgrade 4208 f*ed things up. They revised the hardware to prevent 'charge and ride' , but it came at a cost.



  • @suboba yeah, the thread is hot. And I think is effects more people than they even realize.
    I really don’t want to have to send my board in. That would suck to be without it for an extended period of time. Please keep us updated on how it goes with your board and what FM winds up doing.



  • Have some of you tried to record some of your rides with the app ?
    If yes, didn’t you notice than when playing back a ride, the characters often “teleports” ? I guess it corresponds to disconnects ?



  • @CLBR I don’t think that’s related. It “teleports” if your phone loses GPS and/or data connection. Happened to me a few times in a spotty cell coverage area a few weeks ago, but I had app connection the entire time. The only reason I am so aware of my app connection is because I am constantly checking my Apple Watch to make sure I’m not going too fast. I am so paranoid of nose doves.


Log in to reply