My phone canˈt get along with OW app - "Online activation failed"

  • Hey there,

    [ Preamble :: Well, Iˈve been riding my board for ~3 months now without ever knowing my battery % and speed km/h and odometer lifetime. I know it sounds nuts claiming that .. itˈs been fun! .. while actually I havenˈt got a full functionality out of this crazy uplifting thing. Just havenˈt got any time to strictly deepen into this issue. Back in a beginning of May I set it on "Mission" mode manually and simply rode it ever since.
    -Now that Iˈm off of work for awhile, longside finishing my board customisations, I want to get this app thing cleared out as well. ]

    Decided to make a new topic as none of the previous ones with "BT connection issues" related donˈt quite match with my main symptoms. (Yea I`ve read most of them. Within this community forum and some from reddit as well.)
    Mostly ppl were stuck with either ...

    1. ... having not updated firmware. - Therefore lending someones iPhone to update. (That was a loong ago.)
    2. ... hardware 4208 having poor bluetooth signal (Also: 2018 - early 2019 era)

    My phone just canˈt get properly(*) connected with the official OneWheel app (while the rest of OW related things does) and gives this "Online activation failed" overlay popup which I haven`t seen in any other context discussed.
    *- said "properly", because seemingly there still is some sort of connection between app and the board (reffering to 2nd pic on right) Just that cannot get readings on battery/range nor other stuff. And cannot change the riding modes.
    1. pic collage [1500x1500 96pix].jpg


    board :: OW+ XR // Hardware: 4212 // Firmware: Gemini - 4150

    phone :: AGM X3 // Android 8.1.0 // Bluetooth: 5.0

    app :: version 2.5.7 (the most recent atm)

    What I`ve tried so far:

    1.) Uninstalled app. Cleared all BT devices listing on my phone. Rebooted phone. Installed app from scratch. - Nothing.

    2.) Added the OW app into "App White List" - something that should give the app more advance permissions by all means .. rather than just "trustworthy BT device listing".

    3.) Set the phone on "Airplane Mode" and off ... with and without WiFi enabled ... with and without mobile Data enabled simultaneously - Obviously no effect.

    4.) Tweaked the phone settings like:
    System -> Developer options -> Bluetooth AVRCP Version -> setting it from 1.4 (Default) to 1.6
    -No effect on me. As Iˈve stated out, the BT signal strenght is not the case for me.

    5.) Downloaded the LightBlue app and connected my OW through it - No issues whatsoever! I could even play around with it to monitor how far I can walk with my phone before boards BT signal dissapears. The result was pleasing well, despite ~2019 post were ppl were experiencing cut-offs fairly quite close range. Unfortunately this LightBlue does not have any benefit in communication between official OW app. Moreover .. the board cannot be simultaneously connected with different apps. If itˈs tied with LightBlue, it does not even let you try connecting with OW app and the other way round.
    2. pic collage [1500x994 96pix].jpg

    6.) Well, I also looked towards unoffical/alternative apps. Most of them are either discontinued or inaccessible by now (e.g. POWheel and OWheelBuddy). And Google Play Store does not endorse those anyways. I gave a try on "Onewheel Community Edition" app which can be gained via FB group.
    -As a precondition for using this is starting & force quitting official app first. How ironic!
    3. pic collage [1500x1000 96pix].jpg

    Last week I took nephewˈs iPhone SE and installed OW app on it - connected with my board effortlessly - this is actually how I get to know my XRˈs hardware and firmware version for the very first time in those 3 months!
    This was big leap forward for me - now going further within solving this issue.
    For experimental purpose we took the other nephewˈs Samsung S7 ... and also, boom! No hassle, no issues. Just install `n ride.

    That all been said, Iˈm rather sure Iˈve rounded out the possibilities of unupgraded OW firmware or faulty BT controller or weak BT signal on either boards/phones side.
    Itˈs just that my phone model doesnˈt like this official app for some reason or the other way round. And I canˈt figure out why.

    Can I get pre-2.5.7 versions of the app somewhere?
    Any other ideas?
    Thanks in advance!

  • i don't see restarting the phone on your list of attempted remedies. I couldn't get the widgets to work for weeks. Then I restarted my phone.

  • @NotSure It`s within the 1.)

    But I think I´ve actually rebooted(/restarted) phone every now and then if any next step forward and attempting smth new.

  • @Sirgu oh sry lol. wall o text syndrome. yeah that's a puzzler.

  • @NotSure No worries. Tnx for input!

    Yea I probably should have put everyting in shorter way. Just that Iˈve struggled with it in so many methods that I donˈt want to miss a detail.

  • @Sirgu Well that's weird. Nice work on trying to isolate the issue.

    As you mention later it does sound like the device be it the version of Android or some app interfering with the data being at fault.

    Is this stock Android, tweaked by the phone manufacturer or a completely custom ROM from a 3rd party? Haven't touched android in 3 years but have a bit of experience throwing phones at the wall flashing them with different ROMs and getting all sorts of dumb quirks.

    Regarding app versions I don't believe FM officially catalogue the old versions for download themselves. APKpure hosts older versions of various apps including the Onewheel one but I cannot validate the legitimacy of the downloads so use at your own risk.

  • @Lia Thanks for the APKpure link! I`ll probably give it a try next morning...

    As for the Android 8.1.0 (Oreo) - Yes itˈs kindˈa outdated in 2021 context but it`s not utterly obsolescent. Many ppl run their app on older OS than that. This exact version on my phone is the one that came with the phone and I guess it has some manufacturer tweaks due to claimed OTA push-through updates.
    In general it looks like stock A.8.1

    Unfortunately, chinese brands are notorious of their non-existent customer support and poor after-sales development. Which goes the same with AGM - the phone is superb variant among rugged devices and Iˈm still significantly satisfied with itˈs performance after two years of usage. JUST THAT Android security patch level is 5th june 2019 [Yes, the OTA update have litterally happened once.] Their FB page news feed is flooded by angry customers posts on not getting any updates and fearing applications cease to work. Usually I donˈt go along with fear mongering and this phone really have served me well compared to the previous ones Iˈve had. Havenˈt had any kickbacks. Nevertheless I´ve realised I canˈt ignore that fact forever and eventually have to root my phone one day. As up to the specs it`s lifespan could be noteably something much more than this outdated Android OS.

    @Lia - up to your knowledge.. do you think this outdated security patch could be finally decisive in this case here? And if yes, how come it has an affect on OW app and not on others so far?

  • @Sirgu Hard to say, before I got an iPhone I was using a WifeyFox swift on some variant of Android. The bluetooth on that would always act unbelievably intermittent. The behaviour would change a little depending on what version I updated to so there is some validity to assuming it could be related to a patch causing it.

    Not entirely sure why it's happening though, in your case maybe FM's server is rejecting the data based off of an outdated certificate that the OS handles. Considering other phones work which are presumably running something newer that could be why.

  • Some minor progression. But it`s still odd and not getting much better...

    Today I tried out older versions. Not of all 30 that APKpure provides. But pretty much a ~third of them. Took V2.2.4 for a start point as release date 2019-04-28 is the last one that fits in the frame with my Android security patch. Noted some differences in app behavior compared with latest version. So I started to narrow down options by trying back and forth all versions in between V2.5.7 and V2.2.4 Found the boundary being V2.2.20 (and up). So version 2.2.11 is the one that I kept and have now currently installed.

    So what`s actually different till V2.2.11:

    • I can actually navigate in user interface ... a little bit. All values and readings are still ZERO. But there is not that "Online activation failed" overlay covering the whole thing. Were hitting "OK" simply closed everything, leaving no option to ever see broard settings, diagnostics.
    • In other words: If I`d be still in a state of not knowing my boards hardware and firmware after the purchase - all old versions up to 2.2.11 would have revealed it for me without a need of asking ppl to install the app on their phone and show me.
    • Also noted that app uses therms "connecting, reconnecting" rather instead of "activating". Actually connecting with the board goes lightning fast with whatever versions tried (was even tricky to capture screenshot of connecting momentum). Donˈt quite get why everything from V2.2.20 and up tries to "activate" something while I haven`t touched ride modes and shapings in DS2.0
      3.05 - four pic collage [1500x1500 96pix].jpg

    Does anybody remember app usage back then when new riding modes were first featured? (Was there like 3 shapings overall at first?) Did one had to click somewere to "activate"? .. instead of just swiping left-right on Digital Shaping and waiting a second or two.

    @Lia said :

    maybe FM's server is rejecting the data based off of an outdated certificate that the OS handles.

    If this happens to be true, why they wouldn`t just clearly express it in their policy?! (-rethorical question)
    This sentence - "Online activation failed. Please ensure to have internet connection or try again later" - is so misleading in such case.

    Not much hope left on solving this.
    -Yet one theory I want to try out: Find someone in relatives or friends having good condition phone with Android 7.0 (or earlier) in active use AND someone with whatever Android with just outdated security patch.

  • A bit off topic:

    Aside of repeatedly mentioned LightBlue app thereˈs also this Bluetooth Intensity app out there.
    -Highly recommended for those who want to monitor BT signal strenght on a ride with all the circumstances ˈn stuff (e.g. phone cases, pockets, speed) It`s rather simplified and user friendly, but much more precise and quick corrective.
    So "LightBlue" better for data details and advanced needs.
    "Bluetooth Intensity" better for signal fluctuation monitoring.

  • @Lia said in My phone canˈt get along with OW app - "Online activation failed":

    Not entirely sure why it's happening though, in your case maybe FM's server is rejecting the data based off of an outdated certificate that the OS handles. Considering other phones work which are presumably running something newer that could be why.

    This is probably correct. Debug sux . A certificate error is a fine culprit. The notification may just be a catch-all. Pre-heartbleed OpenSSL is burned.

Log in to reply